Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
owned
Bachrk
 

Posts: 4
Joined: Aug 2018
Location: Tennessee
Post: #1
owned

Copy
(This post was last modified: 27-07-2019 10:41pm by Bachrk.)
27-08-2018 03:50pm
Find all posts by this user Quote this message in a reply
XFullFatTim
Bat wielding forum enforcer

Posts: 9,268
Joined: Oct 2010
Location: Somewhere between here and there.
Post: #2
RE: Worst car I’ve ever owned

Welcome to modern Land Rovers............ I know it should be looked at by the dealership but have you tried a “hard” reset? Disconnect the battery for 10-15 minutes and then reconnect, it often fixes bugs like that. But as I assume it is a fairly new car then the dealership should be the fixer under the warranty

Now driving a 2018MY Mini Countryman Cooper S E All4 PHEV, alongside my 1996 Defender
TDi300. I hope to be back in a new Land Rover in late 2019 or early 2020 but am having a short break
To try something different
27-08-2018 06:27pm
Find all posts by this user Quote this message in a reply
PhilSkill
 

Posts: 3,864
Joined: Jun 2011
Location: Warwickshire
Post: #3
RE: Worst car I’ve ever owned

The coolant level air bubble is a common thing in this engine from the factory, it should lose no more water from now though!

Other than disconnecting and re-linking the phone to the car and the hard reset, then see if you can get it to work with someone else's phone, if not get it back to the dealer.

MY12 Fuji Dynamic SD4 Manual, Pano Roof, Electric Tailgate with own Close module
[Image: 124529.png][Image: 376323.png]
27-08-2018 08:20pm
Find all posts by this user Quote this message in a reply
Koidream
 

Posts: 114
Joined: Dec 2014
Location: Belgium
Post: #4
RE: Worst car I’ve ever owned

I see you had only 2 issues so far. And already frustrated?
I have +10 issues untill now but expecting more...

BMW 315
BMW 518
Daihatsu Rocky 2.8D
BMW 320i
BMW R100RT
Triumph Spitfire 1500
Rover 623 Si
BMW 518i
Alfa Romeo 156 1.9JTD
VOLVO S60 D5
Range Rover Evoque TD4

[Image: 343895.png]
28-08-2018 06:49am
Find all posts by this user Quote this message in a reply
Bachrk
 

Posts: 4
Joined: Aug 2018
Location: Tennessee
Post: #5
owned

Copy
(This post was last modified: 27-07-2019 10:42pm by Bachrk.)
19-09-2018 01:57am
Find all posts by this user Quote this message in a reply
sasdiscos
 

Posts: 127
Joined: May 2016
Location: uk
Post: #6
RE: Worst car I’ve ever owned

Its a shame, hearing so many sad stories of poor landrover reliability, (right across the board) However, I must say my evoque has been the most reliable car ive ever owned. I don't want to jinx it but its never gone wrong.

So many people report problems, and normally very expensive. It is a huge worry for the future I have to say.

Steve
19-09-2018 05:14pm
Find all posts by this user Quote this message in a reply
Bachrk
 

Posts: 4
Joined: Aug 2018
Location: Tennessee
Post: #7
RE: Worst car I’ve ever owned

Copy
(This post was last modified: 19-09-2018 07:12pm by Bachrk.)
19-09-2018 05:37pm
Find all posts by this user Quote this message in a reply
Doody
 

Posts: 104
Joined: Jun 2014
Location: Boston & New York City
Post: #8
RE: Worst car I’ve ever owned

My 2012 Evoque is nearing 100K miles. Absolutely zero major problems.

I too had a recurring low coolant problem - turned out it was a very minor leak - unsurprisingly. One tech finally found it and tightened the clamp. I was putting coolant in every 5000 miles or so - hardly a horrible experience, but admittedly annoying.

FWIW,
Doody

2012 Prestige Premium
24-09-2018 09:47pm
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)
babyRR is an independent web site and not affiliated with Land Rover