Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hi all
JohnRR
 

Posts: 2
Joined: Jul 2019
Location: England
Post: #1
Hi all

   



Hi all

Just purchased a used 2017 Evoque from my local dealer two weeks ago. Very happy but one issue, it displays low battery please start engine on every trip. Seems a common issue when googled but wanted to know if there was a quick fix?

Thanks
(This post was last modified: 20-07-2019 11:34am by JohnRR.)
20-07-2019 11:34am
Find all posts by this user Quote this message in a reply
XFullFatTim
Bat wielding forum enforcer

Posts: 9,252
Joined: Oct 2010
Location: Somewhere between here and there.
Post: #2
RE: Hi all

Welcome to the forums John
Often it is a sign that the battery for the auto stop/start system is dead/ low on charge, it might need replacing - get it back to the dealership while you still gave warranty, they will try to fob you off but it probably needs a new secondary battery. No quick fix for it, and all the LR dealers know about this issue

Now driving a 2018MY Mini Countryman Cooper S E All4 PHEV, alongside my 1996 Defender
TDi300. I hope to be back in a new Land Rover in late 2019 or early 2020 but am having a short break
To try something different
(This post was last modified: 22-07-2019 12:04am by XFullFatTim.)
22-07-2019 12:02am
Find all posts by this user Quote this message in a reply
JohnRR
 

Posts: 2
Joined: Jul 2019
Location: England
Post: #3
RE: Hi all

Thank you
22-07-2019 05:55pm
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)
babyRR is an independent web site and not affiliated with Land Rover