Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Worst car I’ve ever owned
Bachrk
 

Posts: 4
Joined: Aug 2018
Location: Tennessee
Post: #1
Worst car I’ve ever owned

Hello, oh the frustration. I have a 2017 Range Rover Evoque. I can’t use the hands-free phone because anyone who calls hears themselves in such a bad echo that they end up hanging up.

My coolant level alerted me I needed more coolant and the vehicle only has 7000 miles, so I looked, and it did. Took it to the shop they saw no issues whatsoever and said maybe it was an air bubble in the line.

Today when someone actually called and decided to stay on the phone with me despite hearing themselves echo there was more trouble. When they did hang up the stupid car wouldn’t disconnect. I tried everything including turning my own phone off and disconnecting the Bluetooth. I got out of the car turned it off and locked it. Came back 20 minutes later and it still shows the call is connected. I even had the person call me back from that number and then we disconnected again yet the panel still shows connected. Of course this shut the radio down/muted the radio so on top of not being able to get the call to disconnect I also have no radio. I’m taking it in to the shop tomorrow but I have to say so far I am extremely disappointed in this car. You should be able to trust the car you’re driving and I feel very uneasy whenever I have to go anywhere. It might as well be a 1975 Pinto. Ughhh
(This post was last modified: 27-08-2018 03:57pm by Bachrk.)
27-08-2018 03:50pm
Find all posts by this user Quote this message in a reply
XFullFatTim
Bat wielding forum enforcer

Posts: 9,181
Joined: Oct 2010
Location: Somewhere between here and there.
Post: #2
RE: Worst car I’ve ever owned

Welcome to modern Land Rovers............ I know it should be looked at by the dealership but have you tried a “hard” reset? Disconnect the battery for 10-15 minutes and then reconnect, it often fixes bugs like that. But as I assume it is a fairly new car then the dealership should be the fixer under the warranty

Since June 2018 I’m XRRSTim as a 2018MY Mini Countryman Cooper S E All4 PHEV is now charging on my drive
Previously owned
- 2015 RRSport L494 HSE Dynamic SDv6
- 2014 5 Door SD4 Dynamic Plus Lux
- 2011 SD4 Auto Coupe Lux Plus
And 7 other Land Rover products since 1995.
Still on my drive - 1996 TDi300 Defender 90 County
27-08-2018 06:27pm
Find all posts by this user Quote this message in a reply
PhilSkill
 

Posts: 3,827
Joined: Jun 2011
Location: Oxfordshire
Post: #3
RE: Worst car I’ve ever owned

The coolant level air bubble is a common thing in this engine from the factory, it should lose no more water from now though!

Other than disconnecting and re-linking the phone to the car and the hard reset, then see if you can get it to work with someone else's phone, if not get it back to the dealer.

MY12 Fuji Dynamic SD4 Manual, Pano Roof, Electric Tailgate (ask me about my auto close module)
[Image: 124529.png][Image: 376323.png]
27-08-2018 08:20pm
Find all posts by this user Quote this message in a reply
Koidream
 

Posts: 100
Joined: Dec 2014
Location: Belgium
Post: #4
RE: Worst car I’ve ever owned

I see you had only 2 issues so far. And already frustrated?
I have +10 issues untill now but expecting more...

BMW 315
BMW 518
Daihatsu Rocky 2.8D
BMW 320i
BMW R100RT
Triumph Spitfire 1500
Rover 623 Si
BMW 518i
Alfa Romeo 156 1.9JTD
VOLVO S60 D5
Range Rover Evoque TD4

[Image: 343895.png]
28-08-2018 06:49am
Find all posts by this user Quote this message in a reply
Bachrk
 

Posts: 4
Joined: Aug 2018
Location: Tennessee
Post: #5
RE: Worst car I’ve ever owned

Thanks for all the replies. Update-

I was doing 45 miles an hour down the road when they back up camera came on. I took a video of it and took it to the dealership they said they had never seen a vehicle do this before. They ended up replacing some type of electronic control module which if my car was not under warranty it would’ve been $2000.
19-09-2018 01:57am
Find all posts by this user Quote this message in a reply
sasdiscos
 

Posts: 124
Joined: May 2016
Location: uk
Post: #6
RE: Worst car I’ve ever owned

Its a shame, hearing so many sad stories of poor landrover reliability, (right across the board) However, I must say my evoque has been the most reliable car ive ever owned. I don't want to jinx it but its never gone wrong.

So many people report problems, and normally very expensive. It is a huge worry for the future I have to say.

Steve
19-09-2018 05:14pm
Find all posts by this user Quote this message in a reply
Bachrk
 

Posts: 4
Joined: Aug 2018
Location: Tennessee
Post: #7
RE: Worst car I’ve ever owned

Copy
(This post was last modified: 19-09-2018 07:12pm by Bachrk.)
19-09-2018 05:37pm
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)
babyRR is an independent web site and not affiliated with Land Rover