Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New Turbo
redrovor
 

Posts: 36
Joined: Apr 2015
Location: Sin City
Post: #1
New Turbo

I am a fast driver that enjoys the power of turbo/ supercharged cars. That being said, I recently had to bring my evoque in for some lights on on the dash and some warning messages ie... stability control no backup camera lines, selector has to be manually returned to park to shut off engine. Fix was, new steering torque sensor and new backup battery. They also said somehow I had a check engine light on I never saw it but they diagnosed it to be a bad turbo. the turbo was replaced and after getting my evoque back it constantly goes into over boost and "safe mode" (restricted performance) electronics were recalibrated and tested and once again took it out on the freeway, upon acceleraton up to 55-60 (most likely max boost) a soft engine miss and once again car goes into restricted performance mode. This problem has occured four times and has spent weeks at the dealer. Has anyone had this problem? if so what was the fix?
02-10-2018 02:01pm
Find all posts by this user Quote this message in a reply
RogB
 

Posts: 126
Joined: Jul 2016
Location: North Nottinghamshire
Post: #2
RE: New Turbo

not had this on an Evoque but had it on a Vauxhall Insignia 2.0 diesel although im assuming you have the 2.0 petrol turbo.

under acceleration mine would suddenly cut and go into limp mode. I had to pull over, stop the engine for about 5 minutes and then restart and it would be mostly fine for a short while but then do it again.

the Turbo was changed under warranty but it still happened, so after some prompting from me they changed the overboost actuator, a small fuel filter sized component. This fixed the problem for good.

apparently the actuator creates an effect like having a 2nd turbo cut in at the top of the power/rev range. and allow for an extra bit of power under hard acceleration. Mine was sticking in the open position so trying to continuously overboost which the ECU didn't like so switched on the limp mode.

hope this helps.

2012 Evoque Pure 5 door - Santorini Black, 20'' style 6 wheels, privacy, fogs, (accident damaged wreck direct from LR approved :rollSmile
2011 Evoque Prestige 3 door - Indus Silver, gloss black 19'' style 5 wheels, privacy, partial black pack.

and a few Freelander 2 over the yearsLaughing
02-10-2018 03:18pm
Find all posts by this user Quote this message in a reply
redrovor
 

Posts: 36
Joined: Apr 2015
Location: Sin City
Post: #3
RE: New Turbo

so it seems that the waste gate was the culprit!
07-10-2018 03:19am
Find all posts by this user Quote this message in a reply
RogB
 

Posts: 126
Joined: Jul 2016
Location: North Nottinghamshire
Post: #4
RE: New Turbo

good news then Smile

2012 Evoque Pure 5 door - Santorini Black, 20'' style 6 wheels, privacy, fogs, (accident damaged wreck direct from LR approved :rollSmile
2011 Evoque Prestige 3 door - Indus Silver, gloss black 19'' style 5 wheels, privacy, partial black pack.

and a few Freelander 2 over the yearsLaughing
08-10-2018 09:18am
Find all posts by this user Quote this message in a reply
redrovor
 

Posts: 36
Joined: Apr 2015
Location: Sin City
Post: #5
RE: New Turbo

Lol while there I had a Jag XF to drive then a F pace to drive then a XF S I love my evoque but the S model XF was a blast! now my evoque runs and drives perfectly!!!!!
12-10-2018 01:55am
Find all posts by this user Quote this message in a reply
Manuel432
 

Posts: 2
Joined: Aug 2019
Location: Midland tx
Post: #6
RE: New Turbo

When u accelerated with new turbo and were having problems did you happen to hear any type of like clacking noise ? Just replaced with new turbo on my 2013 Evoque and having similar problems but after getting on pedal and coming to a stop it started to misfire and then would idle fine but started throwing the performance restricted code was leaning towards cat converter being bad but read the post and wondering if that may be problem I swapped it on my own due to closest dealership or shop to want to touch it being 4-5 hours away and I’m a aviation tech figured be a easy swap turned into big head ache for me
30-08-2019 11:23pm
Find all posts by this user Quote this message in a reply
Bazz
 

Posts: 21
Joined: Apr 2019
Location: England
Post: #7
RE: New Turbo

Hi,
Could it be a collapsing / split turbo hose??
(This post was last modified: 31-08-2019 07:31pm by Bazz.)
31-08-2019 07:31pm
Find all posts by this user Quote this message in a reply
Manuel432
 

Posts: 2
Joined: Aug 2019
Location: Midland tx
Post: #8
RE: New Turbo

I did look around on it again after reading this article I noticed that a high rev to make some boost in Park the wastegate actuator arm isn’t moving at all gunna try replace and see if may be my problem as it was his hopefully been a headache for me
01-09-2019 12:35am
Find all posts by this user Quote this message in a reply
redrovor
 

Posts: 36
Joined: Apr 2015
Location: Sin City
Post: #9
RE: New Turbo

its expensive for the dealer to do it, and when they did mine it took them two turbos. The new one was an aftermarket replacement now it runs and drives good. I never had a performance issue with the first one but had exhaust smell inside when engine was on and sitting. there seems to be an issue with these eco boost turbos but it deals with the manifold cracking not actual turbo failure.
09-09-2019 12:42am
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)
babyRR is an independent web site and not affiliated with Land Rover